QLUB Adapter - Initial Release...

Nagging hardware related question? Post here!
martyn_hill
Super Gold Card
Posts: 676
Joined: Sat Oct 25, 2014 9:53 am

Re: QLUB Adapter - Initial Release...

Postby martyn_hill » Tue May 04, 2021 9:41 pm

Hi again Chris

OK, so just to be clear, the receiving QL (when sending from the QLUB) continues to 'hang' whether you evoke either the LBYTEs or the 'manual' approach outlined?

Can you CTRL-Space/Break to regain control of the QL, or is it really 'hung'?

Happy to arrange (via PM) a remote session to troubleshoot together if you're free this weekend - let me know.


User avatar
Chr$
Aurora
Posts: 850
Joined: Mon May 27, 2019 10:03 am
Location: Sachsen, Germany

Re: QLUB Adapter - Initial Release...

Postby Chr$ » Tue May 04, 2021 11:18 pm

martyn_hill wrote:Hi again Chris
OK, so just to be clear, the receiving QL (when sending from the QLUB) continues to 'hang' whether you evoke either the LBYTEs or the 'manual' approach outlined?

Yes, and at the other end it shows Tx Blk#0 and doesn't go any further.
martyn_hill wrote:Hi again Chris
Can you CTRL-Space/Break to regain control of the QL, or is it really 'hung'?

Yes, when using MGG/JS (you have to press it a few times), but Minerva 1.98 does completely hang and won't break out - has to be reset (but doesn't crash like that with the non LBYTES routine - it just never receives anything).
martyn_hill wrote:Happy to arrange (via PM) a remote session to troubleshoot together if you're free this weekend - let me know.

Yes, that should be ok. I may have to set it up differently here though, as I have to walk through rooms to the QL, it's probably about 8m away from the PC running with QLUB. I did just try it out with another, completely unaltered QL with original JS and a TK2 (2.2) dongle hanging out the back, and it was the same, it simply won't receive. And just to confirm I'm not going mad I did also send/receive to/from the Q68 from the QLUB end again and that was still perfectly fine in both directions, so I suppose that rules out any issue with my PC setup. And the fact that it was the same with the other QL probably rules out any issues with the main QL.

I did also notice that when sending to the QLUB a one stage it wouldn't work either and I accidentally discovered that I had to fiddle with the USB connection (not the 3.5cm jack), which was odd. So when attempting to send I also fiddled with the QLUB USB connection but that didn't improve matters.

Could the rather long cable be an issue? I think next I'll try moving things around so I can use a shorter cable. It's a good quality mic cable but is the only thing left that I can perhaps rule out.


Collector of QL related computers, accessories and software even though I don't really understand how they work!
Original QL's: many (plus quite a bit of other old stuff and 170+ original software titles)
Custom XT cased QL system with Gold Card, Qimi mouse, Hermes and MFM HDD
QXLII card installed in a PC
Q40 and Q68 also present

Ask me about near NOS re-felted good quality Microdrive Carts - many available.
martyn_hill
Super Gold Card
Posts: 676
Joined: Sat Oct 25, 2014 9:53 am

Re: QLUB Adapter - Initial Release...

Postby martyn_hill » Wed May 05, 2021 2:13 am

Hi Chris!

Right, that's clear now.

When using Minerva, you are hitting the serio IO bug, but when using MG/JS, the QL is simply not accepting the packets from the QLUB - hence responding as expected to Break.

Given that, one might expect that even once you update your Minerva image to v1.98 a1 - correcting the serio IO bug - you'll still hit the same issue as per the MG/JS QL tests.

That leaves us with either:
a) The net timing-constants needing further adjustment (possible), or else
b) That cable-run (suspect) or
c) Some other hardware issue with (both) QLs rendering the NET ports less than 100% reliable and yet still able to connect with a Q68 (seems unlikely)

If the problem is with a), then as of v2.2a and later of the QLUB firmware, it is quite straightforward to adjust the timing-constants, which appear in the DATA statements near the end of the SendFileMQ program. We can come back to that later, if needed.

If b) - my inclination at this point - then have you successfully tested the NET connection between the two QLs with that same cable? Or tried the Q68 to QL, but this time with that same long cable? Just how long is the cable? I've seen success with a 10m cable, myself.

Out of interest, which version of the QLUB firmware and SendFileMQ program are you running?


User avatar
Chr$
Aurora
Posts: 850
Joined: Mon May 27, 2019 10:03 am
Location: Sachsen, Germany

Re: QLUB Adapter - Initial Release...

Postby Chr$ » Wed May 05, 2021 1:19 pm

martyn_hill wrote:If b) - my inclination at this point - then have you successfully tested the NET connection between the two QLs with that same cable? Or tried the Q68 to QL, but this time with that same long cable? Just how long is the cable? I've seen success with a 10m cable, myself.

Out of interest, which version of the QLUB firmware and SendFileMQ program are you running?


v22a on the Teensy (programmed using the .hex file). SendMyFile is v2.2.

I'd underestimated the cable length, it's a whopping 12.8 metres!

I tried the 12.8m long cable between QL and Q68 and was able to send from and receive to the QL (QL running MGG on that occasion). Both computers are physically very close and the cable was therefore in the same room on the floor. I suppose it could be some kind of interference along the original cable route.

I think I really should move the QLUB PC closer to the QL (or vice versa) and try it again with a sensible cable, i.e. the same short one that I normally use between Q68 > QL.

Will report back.


Collector of QL related computers, accessories and software even though I don't really understand how they work!
Original QL's: many (plus quite a bit of other old stuff and 170+ original software titles)
Custom XT cased QL system with Gold Card, Qimi mouse, Hermes and MFM HDD
QXLII card installed in a PC
Q40 and Q68 also present

Ask me about near NOS re-felted good quality Microdrive Carts - many available.
User avatar
Chr$
Aurora
Posts: 850
Joined: Mon May 27, 2019 10:03 am
Location: Sachsen, Germany

Re: QLUB Adapter - Initial Release...

Postby Chr$ » Wed May 05, 2021 7:06 pm

Right, I moved things around and tried again with a normal shorter cable and it's the same! i.e. I can:

Send files from QLUB (Qemulator or QPC) to Q68.
Receive files on QLUB from Q68.
Send files from QL with MGG to QLUB.
Send files from the other QL with JS to QLUB.

It still gets stuck at Blk#0 (and I have to break out) when I attempt to send files from QLUB to either QL.

I've checked the little MK PCBs and they seem fine, resistors are correct, soldering is good etc. I have 3 made up now and have tried all with the same results. The only slight deviation from the original plan is that I have used ZTX550 transistors, but we covered that earlier in the thread and they should be a suitable alternative.

When I talked with Maskenlos Stephan he did send me details of an alternative data statement for the timings that you had provided when he was getting up and running, which I think had only one value different to how it was originally. I've since tried that and the original with no success. Happy to try some different values there, it's very easy to change them.

I did notice today that a Teensy I got recently has a red LED, whereas the other 2 I already had have a blue LED. I'm sure that's irrelevant.


Collector of QL related computers, accessories and software even though I don't really understand how they work!
Original QL's: many (plus quite a bit of other old stuff and 170+ original software titles)
Custom XT cased QL system with Gold Card, Qimi mouse, Hermes and MFM HDD
QXLII card installed in a PC
Q40 and Q68 also present

Ask me about near NOS re-felted good quality Microdrive Carts - many available.
User avatar
mk79
Aurora
Posts: 960
Joined: Sun Feb 02, 2014 10:54 am
Location: Esslingen/Germany
Contact:

Re: QLUB Adapter - Initial Release...

Postby mk79 » Wed May 05, 2021 7:17 pm

The PCB was designed for the BC559 transistor, which if I'm not mistaken has the pins exactly the other way round compared to your ZTX550... I can't explain why the Q68 can get what your sending, but it would certainly explain why a QL can't.


User avatar
Chr$
Aurora
Posts: 850
Joined: Mon May 27, 2019 10:03 am
Location: Sachsen, Germany

Re: QLUB Adapter - Initial Release...

Postby Chr$ » Wed May 05, 2021 7:42 pm

mk79 wrote:The PCB was designed for the BC559 transistor, which if I'm not mistaken has the pins exactly the other way round compared to your ZTX550... I can't explain why the Q68 can get what your sending, but it would certainly explain why a QL can't.

OMG, so it does!

Right, swapping them round...


Collector of QL related computers, accessories and software even though I don't really understand how they work!
Original QL's: many (plus quite a bit of other old stuff and 170+ original software titles)
Custom XT cased QL system with Gold Card, Qimi mouse, Hermes and MFM HDD
QXLII card installed in a PC
Q40 and Q68 also present

Ask me about near NOS re-felted good quality Microdrive Carts - many available.
User avatar
Chr$
Aurora
Posts: 850
Joined: Mon May 27, 2019 10:03 am
Location: Sachsen, Germany

Re: QLUB Adapter - Initial Release...

Postby Chr$ » Wed May 05, 2021 8:07 pm

Yes, it works perfectly now! I just sent a screen to the QL in the other room.

Thanks Marcel, sorry for being such a noob and sorry for wasting your time Martyn, with a problem for which I was entirely to blame.

So, 12.8m cables do work perfectly, at least I have confirmed that :oops:


Collector of QL related computers, accessories and software even though I don't really understand how they work!
Original QL's: many (plus quite a bit of other old stuff and 170+ original software titles)
Custom XT cased QL system with Gold Card, Qimi mouse, Hermes and MFM HDD
QXLII card installed in a PC
Q40 and Q68 also present

Ask me about near NOS re-felted good quality Microdrive Carts - many available.
martyn_hill
Super Gold Card
Posts: 676
Joined: Sat Oct 25, 2014 9:53 am

Re: QLUB Adapter - Initial Release...

Postby martyn_hill » Wed May 05, 2021 9:42 pm

Great news!

Glad to hear you're now fully connected :-)


User avatar
mk79
Aurora
Posts: 960
Joined: Sun Feb 02, 2014 10:54 am
Location: Esslingen/Germany
Contact:

Re: QLUB Adapter - Initial Release...

Postby mk79 » Thu May 06, 2021 9:01 am

Chr$ wrote:Yes, it works perfectly now! I just sent a screen to the QL in the other room.
Cool, glad I could help :-)
Thanks Marcel, sorry for being such a noob and sorry for wasting your time Martyn, with a problem for which I was entirely to blame.
No worries, but good thing you mentioned this little detail ;)

Cheers, Marcel



Who is online

Users browsing this forum: No registered users and 4 guests