Ubuntu 14.04.4 and uqlx2017

Discussion and advice about emulating the QL on other machines.
User avatar
XorA
Super Gold Card
Posts: 562
Joined: Thu Jun 02, 2011 11:31 am
Location: Shotts, North Lanarkshire, Scotland, UK

Re: Ubuntu 14.04.4 and uqlx2017

Postby XorA » Wed Sep 12, 2018 4:12 pm

dilwyn wrote:
Derek_Stewart wrote:Hi,

I downloaded the UQLX2017 source file from QL Homepage:

http://www.dilwyn.me.uk/emu/uqlx-fork-master.zip

There is no uqlx.html file in the docs dirctory, whereas on github the file is there. why the :roll: difference, as the missing doc file gives import information with regards to UQLX.

Thanks Derek.
Not knowing the first thing about uQLx and being afraid of breaking the archive or something, what I've done is to add the uqlx.html as a separate file just after the uQLx 2017 sources on the Emulators page. Hope this helps.


The .html file is built as part of building uqlx ;-)


Martin_Head
Gold Card
Posts: 353
Joined: Tue Dec 17, 2013 1:17 pm

Re: Ubuntu 14.04.4 and uqlx2017

Postby Martin_Head » Thu Sep 20, 2018 11:03 am

I e-mailed Graeme Gregory to ask if the IP Device Driver was working in UQLX 2017. He says that he has never used IP on UQLX.

From a search on the web, I found that back in 2009 someone was having problems getting the IP driver to work when compiling UQLX. Something to do with the version of the software used to the compiling.

So as I can't seem to get the driver working, I am going to assume that the IP Device Driver does not work, or does not work correctly in UQLX 2017.


User avatar
XorA
Super Gold Card
Posts: 562
Joined: Thu Jun 02, 2011 11:31 am
Location: Shotts, North Lanarkshire, Scotland, UK

Re: Ubuntu 14.04.4 and uqlx2017

Postby XorA » Thu Sep 20, 2018 12:46 pm

Martin_Head wrote:I e-mailed Graeme Gregory to ask if the IP Device Driver was working in UQLX 2017. He says that he has never used IP on UQLX.

From a search on the web, I found that back in 2009 someone was having problems getting the IP driver to work when compiling UQLX. Something to do with the version of the software used to the compiling.

So as I can't seem to get the driver working, I am going to assume that the IP Device Driver does not work, or does not work correctly in UQLX 2017.


Have you got a link to that discussion?

Also do you have a simple test case? I think Dilwyn did post one ages ago but I forgot where.

I have a couple of days hols next week so I might get a chance to take a look and see what the deal is with uQlx!


User avatar
tofro
QL Wafer Drive
Posts: 1441
Joined: Sun Feb 13, 2011 10:53 pm
Location: SW Germany

Re: Ubuntu 14.04.4 and uqlx2017

Postby tofro » Thu Sep 20, 2018 12:55 pm

The uQLx versions I built years ago for the Raspberry Pi and the Efika actually had a working TCP/IP driver (although I never tested it beyond some basic packet transfer tests, and definitely not against your driver, which didn't exist at that time).

That means: It should in principle be working, as I don't assume there have been lots of changes. The exact problem what doesn't work with your setup should be worked out, and I'm sure that can be fixed.

Tobias


ʎɐqǝ ɯoɹɟ ǝq oʇ ƃuᴉoƃ ʇou sᴉ pɹɐoqʎǝʞ ʇxǝu ʎɯ 'ɹɐǝp ɥO
User avatar
dilwyn
Mr QL
Posts: 1385
Joined: Wed Dec 01, 2010 10:39 pm
Location: Wales
Contact:

Re: Ubuntu 14.04.4 and uqlx2017

Postby dilwyn » Thu Sep 20, 2018 2:52 pm

XorA wrote:
Martin_Head wrote:I e-mailed Graeme Gregory to ask if the IP Device Driver was working in UQLX 2017. He says that he has never used IP on UQLX.

From a search on the web, I found that back in 2009 someone was having problems getting the IP driver to work when compiling UQLX. Something to do with the version of the software used to the compiling.

So as I can't seem to get the driver working, I am going to assume that the IP Device Driver does not work, or does not work correctly in UQLX 2017.


Have you got a link to that discussion?

Also do you have a simple test case? I think Dilwyn did post one ages ago but I forgot where.

I have a couple of days hols next week so I might get a chance to take a look and see what the deal is with uQlx!

Not so much a test case as just some notes on how to use it from BASIC, the notes are here http://www.dilwyn.me.uk/docs/uqlx_tcp/index.html


Dilwyn
All things QL: see www.dilwyn.me.uk
swensont
Forum Moderator
Posts: 131
Joined: Tue Dec 06, 2011 3:30 am
Location: SF Bay Area
Contact:

Re: Ubuntu 14.04.4 and uqlx2017

Postby swensont » Thu Sep 20, 2018 8:05 pm

IIRC, I did some simple testing of IP on the different emulators. IIRC, I think it worked on uQLx but the syntax was different than SMSQmulator. I can retest this weekend.

Tim


User avatar
mk79
Trump Card
Posts: 222
Joined: Sun Feb 02, 2014 10:54 am

Ubuntu 14.04.4 and uqlx2017

Postby mk79 » Thu Sep 20, 2018 8:34 pm

Well, uQLx is the original implementation for TCP/IP for QDOS, all applications were originally developed for it. Then I implemented the same interface for QPC and eventually Wolfgang did it for SMSQmulator based on QPC‘s source code, but that was only a few months ago.
If they don‘t behave the same then it‘s a bug.


User avatar
XorA
Super Gold Card
Posts: 562
Joined: Thu Jun 02, 2011 11:31 am
Location: Shotts, North Lanarkshire, Scotland, UK

Re: Ubuntu 14.04.4 and uqlx2017

Postby XorA » Fri Sep 21, 2018 1:37 am

Note the change from *TCP_ to TCP_ is a two line patch if someone fancies changing that ;-)


swensont
Forum Moderator
Posts: 131
Joined: Tue Dec 06, 2011 3:30 am
Location: SF Bay Area
Contact:

Re: Ubuntu 14.04.4 and uqlx2017

Postby swensont » Fri Sep 21, 2018 4:45 am

What XorA is getting at is that the socket in UQLX is not "TCP" but "*TCP". Here is the one line from Dilwyn's example program:

150 OPEN_IN #3,"tcp_www.dilwyn.me.uk:80"

To get it to work with UQLX, just add a * :

150 OPEN_IN #3,"*tcp_www.dilwyn.me.uk:80"

And this now works (I just tested it). Now, programs like Lynx are probably not expecting the *, so that might be why Lynx failed on UQLX. Like XorA said, a simple change in QLip.c :

static const char *dnms[] = {"*tcp,","*udp","*uxs","*uxd","*sck",NULL};

to edit out the *.

Tim


User avatar
dilwyn
Mr QL
Posts: 1385
Joined: Wed Dec 01, 2010 10:39 pm
Location: Wales
Contact:

Re: Ubuntu 14.04.4 and uqlx2017

Postby dilwyn » Fri Sep 21, 2018 10:45 am

swensont wrote:What XorA is getting at is that the socket in UQLX is not "TCP" but "*TCP".

Err, why? Is it a bug?


Dilwyn
All things QL: see www.dilwyn.me.uk

Return to “QL Emulation”

Who is online

Users browsing this forum: No registered users and 1 guest